PHP5.5 has now reached its “end of life” and is no longer supported by the PHP project. This means that no security updates are provided and to keep servers and sites secure, an upgrade to PHP5.5 is necessary.

At GBC, we've upgraded all our servers to PHP5.5. Site owners are advised to check their services to make sure they are running. We shall offer the ability to switch between PHP 5.3/4/5 for several months.

When PHP reaches the EOL (end of life), the PHP team stops supporting that version. This means not only there won't be any more new features or bug fixes, but also that no security issues will be addressed, leaving your sites vulnerable.

PHP EOL


PHP5.5 compatible versions are:

Magento Community Editions 1.6.x, 1.7.x and 1.8.x require the “PHP5.4 support patch”. Community Edition 1.9.1.0 is PHP5.5 compatible and can be downloaded here (scroll to bottom of page): www.magentocommerce.com/download

Zen Cart versions 1.5.0 and 1.5.1 require patches to work with PHP5.4. Older versions 1.3.8 and 1.3.9 will not run on PHP5.4. The next version 1.5.2 will run natively with 5.4 but as this currently in beta, we do not recommend to use it yet for live production sites. For details see www.zen-cart.com/content.php?48-what-are-the-server-requirements-to-run-zen-cart and to download the current 1.5.1 version go to www.zen-cart.com/content.php?19-download. Zen Cart patches to apply to 1.5.x are:

openCart does not provide any official information on PHP5.4 compatibility, but versions 1.5.4.x or higher should all work well. The current OC version is 1.5.6.1, for details and downloads see www.opencart.com/index.php?route=download/download

osCommerce is compatible with PHP5.5 since version 2.3.3.0 or higher https://library.oscommerce.com/Online&en&oscom_2_3&release_notes&v2_3_3_2

WordPress versions appear to run well on PHP 5.4 and 5.5. The main problems with WordPress can be plugins – if you encounter a blank screen (fatal PHP error) or error messages. To download the current 4.5.3 version go to wordpress.org/download/.

Joomla versions 1.6.x, 1.7.x, 2.5.x and 3.x all run on PHP5.5, for details see www.joomla.org/technical-requirements.html. The older Joomla 1.5.x has serious security flaws, making it a prime target for exploits by hackers. Anyone running Joomla 1.5.x versions is strongly recommended to upgrade to Joomla 3.x as soon as possible.

Drupal version 7 should run well on PHP5.5 but the older version 6 is unlikely to work on 5.5 mainly due to incompatible plugins. For more information on PHP compatibility see drupal.org/requirements/php and to download the current 8.17 version go to drupal.org/download.

Goes without saying that by upgrading PHP you will also gain a 9x boost in speed for your site, without doing anything but upgrading.

Do get in touch with us should you need any clarification or assistance with the migration.



Tuesday, July 19, 2016







« Back

Powered by WHMCompleteSolution